DFU Mode not working on Windows 10

Jan 12, 2021 - 6:24 PM

  • Hello,

    I'm trying to update the firmware for my MIDI Commander. However, when I run the device in DFU mode on Windows and open the DFU app, there is no device in the drop down menu.

    While it's recognizing my device, my Device Manager on Windows says there is something wrong with the driver.

    Is there a way to make this work? I'd like to update the firmware to the be able to use MOME.

    Thanks.

    Shaheed

    0
  • Hey try this. UNPLUG usb from midi commander from pc. Goto Device Manager on windows 10. View>Hidden Devices . Look for tsmididfu. Mine was under other devices. Uninstall/remove this driver. Now plug in Midi Commander (Make sure power is off when you plug in usb) Hold D and Down arrow at the same time and power the device on. This allowed windows to properly install DFU mode for me. I was able to update my firmware and am now happily looping in Ableton with the looper plugin and midi commander using the momentary mode (Holding A when turning on after updating firmware for this feature, Momentary Control Mode). I think the root of this problem is if you don't enter DFU mode the very FIRST time you plug the device into a windows machine it won't install this mode properly until you remove the driver and plug it in fresh in this mode BEFORE any other mode. Unfortunately this DFU driver is only visible when showing hidden device in the device manager which has caused alot of people many problems with this device. They need to fix this or explain it in proper English.

    This post was edited Jan 13, 2021 12:54AM
    2
  • Hello, I have done the following and it has detected me.
    After completing the steps described by Midi Master, Windows 10 told me that the driver is not properly installed, so right-click it indicates update the driver and then you indicate that it update with Windows update. In Windows update you look for updates and then press the option to see optional updates, in optional updates you select STMicroelectronics - Other hardware - STM Device in DFU Mode and with that it has detected me.
    Cheers

    1
  • I bought new Midi commander. but I can't use it because of freezing problem. To fix it, I downloaded DFU_Package+190813.zip and follewd the DFU_Userguide. but my commander can't enter the DFU mode. I followed Midi Master. But still my new midicommaner is not recognized at DFUDemo. Even I tried it with new another computer. The result was same. The seller didn't accept to refund with useless commander. So I was forced to buy it. I don't wanna waste A new midi commander. If there's any way, please let me know. Plz, help me.

    This post was edited Apr 27, 2021 09:41AM
    0
  • I was thinking my unit was defective, but finally i figured it out:

    • install Windows DFU Program
    • Go to C:\Program Files (x86)\STMicroelectronics\Software\DfuSe v3.0.6\Bin\Driver\Win10
    • run this dpinst_amd64.exe

    now the driver should be correctly installed and dfu mode detected

    2
  • ronald ortiz - I just figured it out too and should have looked closer here !

    I am going to list every step needed to fix the freeze issue.

    Go to the midi commander downloads page at https://meloaudio.com/pages/manual

    Download the zip file under the name Windows DFU program.

    The zip file is called en.stsw-stm32080.zip

    Extract the downloaded zip file , and run the installer which is called DfuSe_Demo_V3.0.6_Setup.exe.

    This file is the actual installer file, even though it has demo in the name.

    This creates a folder here : C:\Program Files (x86)\STMicroelectronics\Software\DfuSe v3.0.6

    The part that confused me is that the installer is really not finished at this point.

    You still have to manually drill in to this subfolder bin/driver to install your drivers, this is the step that really threw me, it might be mentioned somewhere but I never saw it .

    In the subfolder bin/driver are folders for Win7,Win8,Win8.1 and Win10

    In my case I need Win10, and in here are two files: dpinst_amd64.exe and dpinst_x86.exe

    In my case I need the amd64 version - even though I have an intel machine, the names are really to separate 32 bit and 64 bit versions ( another gotcha, I would normally expect to ignore any file with amd in the name )

    Now when you run that file, dpinst_amd64.exe, it finally installs the drivers.

    Now you can go back to the midi-commander install page and download Freeze-Fixed.

    This will download a file called DFU_Package_190813.zip

    Unpack and you get a folder right there ( in my case C:Downloads\DFU_Package_190813\MidiCommander_DFU_APP )

    This has the app DfuSeDEmo.exe.

    If your hardware is now set up as shown ( hold down D and Set and power on ) then you can run this, you can follow the pdf user guide now, and navigate up one folder to load the file TSMIDI_DFU_V3_STD2.dfu

    Finally it should upload to the hardware, and in my case it does indeed fix the USB freezing issue.

    0
  • Midi Master (@midimaster):
    Hey try this. UNPLUG usb from midi commander from pc. Goto Device Manager on windows 10. View>Hidden Devices . Look for tsmididfu. Mine was under other devices. Uninstall/remove this driver. Now plug in Midi Commander (Make sure power is off when you plug in usb) Hold D and Down arrow at the same time and power the device on. This allowed windows to properly install DFU mode for me. I was able to update my firmware and am now happily looping in Ableton with the looper plugin and midi commander using the momentary mode (Holding A when turning on after updating firmware for this feature, Momentary Control Mode). I think the root of this problem is if you don't enter DFU mode the very FIRST time you plug the device into a windows machine it won't install this mode properly until you remove the driver and plug it in fresh in this mode BEFORE any other mode. Unfortunately this DFU driver is only visible when showing hidden device in the device manager which has caused alot of people many problems with this device. They need to fix this or explain it in proper English.

    100% Working soloution......A+++

    0
  • guys, i found the solution if DFU doesn't recognize your device. Like everybody said, the issue is windows doesn't detect your driver correctly.
    Go to your directory:
    STMicroelectronics\Software\DfuSe v3.0.6\Bin\Driver\Win10
    and select dpinst_amd64 or dpinst_x86 according your PC.
    this solution will re install the driver correctly.
    then go to DFU and you will see the device on the list ;)

    1
  • Bingen Markes (@bingenmarkes):
    Hello, I have done the following and it has detected me.
    After completing the steps described by Midi Master, Windows 10 told me that the driver is not properly installed, so right-click it indicates update the driver and then you indicate that it update with Windows update. In Windows update you look for updates and then press the option to see optional updates, in optional updates you select STMicroelectronics - Other hardware - STM Device in DFU Mode and with that it has detected me.
    Cheers

    Thanks, it works.

    0
  • Just wanted to add -- For me, the device kept showing up in the Device Manager as Guillemot STM DFU Device. I think this driver was from my ThrustMaster flight controller based on minimal research, but I'm not 100% sure. Anyways, I had to delete C:\Program Files\Guillemot and C:\Program Files (x86)\Guillemot, then uninstalled the Guillemot STM DFU Device in Device Manager, then installed the right driver from C:\Program Files (x86)\STMicroelectronics\Software\DfuSe v3.0.6\Bin\Driver\Win10. Once I did that, the DfuSeDEmo.exe detected my MIDI Commander in DFU mode, and I was able to successfully install the All CC# Mode firmware.

    0
  • ronald ortiz (@ronaldortiz):
    I was thinking my unit was defective, but finally i figured it out:
    now the driver should be correctly installed and dfu mode detected

    It worked for me!

    0